fbpx

Stay Home & Grab 20% Discount COVID19Grab Now

Welcome, Guest
Username: Password: Remember me

TOPIC: Cannot turn off Read Time as default

Cannot turn off Read Time as default 4 days 13 hours ago #22403

  • heretic
  • heretic's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 3
  • Karma: 0
My articles started to display the Read Time, although it is turned off in Astroid, and all articles have the Read Time set to Inherit in their Blog Options.
I tried to switch the options there and back again in both Astroid and an article, but without success.
Now the only way how to turn the Read Time off is to set the Read Time option in each article to Hide.

I have Joomla 3.9.18, Astroid 2.3.0, JD Builder Pro 1.6.1, JD Coax 1.3.
I am under WAMP - the site is not online yet.
Last Edit: 4 days 13 hours ago by heretic.
The administrator has disabled public write access.

Cannot turn off Read Time as default 10 hours 40 minutes ago #22486

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3704
  • Thank you received: 543
  • Karma: 96
Hi,

Thank you for your post. I apologize for the delayed reply. I think it's a valid bug. We'll get it fixed in the upcoming release. For the moment, you'll just have to turn it off in every article or remove it from the template layout file. I can help with the instructions for that if needed.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Cannot turn off Read Time as default 10 hours 35 minutes ago #22487

  • heretic
  • heretic's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 3
  • Karma: 0
Thanks for confirmation. I tried to find where in the code the error comes from, but without success :).
The administrator has disabled public write access.

Cannot turn off Read Time as default 10 hours 27 minutes ago #22488

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3704
  • Thank you received: 543
  • Karma: 96
Just comment the following line in the coax template override file.

github.com/joomdev/Astroid-Framework/blo...t/info_block.php#L43

Thank You,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Cannot turn off Read Time as default 10 hours 1 minute ago #22489

  • heretic
  • heretic's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 3
  • Karma: 0
Ah, someone forgot the condition there :). Thanks for clarification.
The administrator has disabled public write access.

Cannot turn off Read Time as default 9 hours 54 minutes ago #22490

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3704
  • Thank you received: 543
  • Karma: 96
Well, the condition is actually there but for some reason not calculating right. You can see the code here:
github.com/joomdev/Astroid-Framework/blo...ork/article.php#L146

It's looking at both Article level and Astroid settings but again, not working. We'll have it fixed!
Again, I do apologize for the delayed reply.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Cannot turn off Read Time as default 9 hours 30 minutes ago #22491

  • heretic
  • heretic's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 3
  • Karma: 0
Indeed, you are right - the condition is in the function. I already went through this code before but couldnt find the problem. A little mystery :)
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.361 seconds