fbpx

Trick or Treat - 30% OFF - Coupon Code: SCARY20 Grab the Deal!

Welcome, Guest
Username: Password: Remember me

TOPIC: (SOLVED) 404 error settings and noindex - nofollow

[SOLVED] 404 error settings and noindex - nofollow 5 months 1 day ago #22513

  • Chacapamac
  • Chacapamac's Avatar
  • Offline
  • Elite Member
  • Posts: 166
  • Thank you received: 4
  • Karma: 0
Are your error.php add a nofollow/noindex to your 404 generated page ?

Like that it is not pickup by search engines.
Last Edit: 4 months 3 weeks ago by Chacapamac.
The topic has been locked.

404 error settings and noindex - nofollow 5 months 10 hours ago #22545

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4153
  • Thank you received: 609
  • Karma: 108
oh sure, good tip!

Does the default joomla has it too?
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22637

  • Chacapamac
  • Chacapamac's Avatar
  • Offline
  • Elite Member
  • Posts: 166
  • Thank you received: 4
  • Karma: 0
After looking around I’m note sure if Joomla error page follow these guideline and how.

I will investigate, anyway 404 page should be removed from Search engines by using the nofollow, noindex in Joomla itself or by the robots.text

In Joomla 3 and 4, I see 2 error.ph file, one in the template in use and one in templates > system.
— I guess the one in the template in use is the right one ?

I will look into the matter.
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22640

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4153
  • Thank you received: 609
  • Karma: 108
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22648

  • Chacapamac
  • Chacapamac's Avatar
  • Offline
  • Elite Member
  • Posts: 166
  • Thank you received: 4
  • Karma: 0
Yep, Thats the one in templates> system > error.php for Joomla 3.

The one for Joomla 4 seem different.

Nowhere I see anything that add the nofollow/noindex,
I wonder, I will ask on Joomla and come back here

I see nothing in the robots.txt ?
# If the Joomla site is installed within a folder 
# eg www.example.com/joomla/ then the robots.txt file 
# MUST be moved to the site root 
# eg www.example.com/robots.txt
# AND the joomla folder name MUST be prefixed to all of the
# paths. 
# eg the Disallow rule for the /administrator/ folder MUST 
# be changed to read 
# Disallow: /joomla/administrator/
#
# For more information about the robots.txt standard, see:
# http://www.robotstxt.org/orig.html
#
# For syntax checking, see:
# http://tool.motoricerca.info/robots-checker.phtml

User-agent: *
Disallow: /administrator/
Disallow: /bin/
Disallow: /cache/
Disallow: /cli/
Disallow: /components/
Disallow: /includes/
Disallow: /installation/
Disallow: /language/
Disallow: /layouts/
Disallow: /libraries/
Disallow: /logs/
Disallow: /modules/
Disallow: /plugins/
Disallow: /tmp/
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22676

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4153
  • Thank you received: 609
  • Karma: 108
Let me know what they say!
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22733

  • Chacapamac
  • Chacapamac's Avatar
  • Offline
  • Elite Member
  • Posts: 166
  • Thank you received: 4
  • Karma: 0
Was respond by Brian Teeman.
If using the Joomla error page then you get a 404 in the response header. Google does not index pages that give a 404 response header so there is nothing for you to do.

I check the error.php and I’m not sure how its done and no idea with Astroid module way....

Anyway I will probably take the Joomlashsck way (20219) — www.joomlashack.com/blog/joomla/404-pages/

I think this is the most elegant way and I’m sure it will be nofollow-noindex.
What do you think?
The topic has been locked.

404 error settings and noindex - nofollow 4 months 3 weeks ago #22755

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4153
  • Thank you received: 609
  • Karma: 108
It's the HTTP Header. You can use httpstatus.io to check the HTTP header of any page.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.
The following user(s) said Thank You: Chacapamac

[SOLVED] 404 error settings and noindex - nofollow 4 months 3 weeks ago #22777

  • Chacapamac
  • Chacapamac's Avatar
  • Offline
  • Elite Member
  • Posts: 166
  • Thank you received: 4
  • Karma: 0
Cool Tool Chetan, To keep in my toolbox

Good Day To JoomDev — SOLVED for me
The topic has been locked.
Moderators: chandandeep
Time to create page: 0.398 seconds