fbpx

Astroid 2.4 Landed with Joomla 4 Compatibility Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: (SOLVED)Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 4 days ago #23958

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Luckily I did not update my live site, but getting major error in Localhost. Updated the Astroid Framework to 2.4.1 and the Template Zero to the latest 2.4.0 and now getting Error: 0 Call to a member function get() on null on every page. The admin still works which is good news I guess.
I didn't know the Astroid Zero Template was affected also, I read the other posts regarding this but the default template was not mentioned. Please tell me a fix is coming quickly...
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 4 days ago #23974

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 1269
  • Thank you received: 123
  • Karma: 16
Hi,

Yes this shouldn't be happening with Astroid template zero users, not sure why did this happened but can you please tell what was your last version that you updated from so I can re create and check the same on my end and provide you the correct solution.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 4 days ago #23981

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Upgraded from 2.3.0 template & framework.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 3 days ago #23997

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Maybe this will help. I turned on debugging & error reporting and this is what comes up. It is indeed either the framework or template causing the issue.
I found the original Error 0 had to do with files in the HTML/Frontend that I had edited. But still getting a different Error 0 even after removing those files.
Last Edit: 3 weeks 3 days ago by vbctv2005.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 3 days ago #24000

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Here is the original error debugged from the edited files in the html/frontend folder. From what I'm seeing, it all revolves around the same error, even after I delete those files.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 3 days ago #24006

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Ok I've narrowed it down. After deleting the files out of the html/frontend folder (which is something that shouldn't have had to be done either) it still gives me the MenuHelper error. But it will load pages that do not have YooTheme Zoo or YooTheme Widgetkit stuff on them. So the error has something to do with those two components. Which 2.3.0 never was affected by. So it's on the framework/template side for sure since 2.3.0 worked with those components.

Sorry about the amount of posts, but trying to help you guys at the same time.
Last Edit: 3 weeks 3 days ago by vbctv2005.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 3 days ago #24010

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Search also comes up with the same MenuHelper error. So basically every page that doesn't use Zoo, WidgetKit & Search works. I've now gone through every page on my site in localhost and tested them all. So anything that uses those 3 components comes back to the MenuHelper error...
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 3 weeks 1 day ago #24127

  • vbctv2005
  • vbctv2005's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 1
Is this something that is going to be fixed soon? Haven't heard anything in 2 days...
The topic has been locked.
The following user(s) said Thank You: Ethlaegil

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 2 weeks 5 days ago #24190

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 1269
  • Thank you received: 123
  • Karma: 16
Hi,

Sorry for the late reply, we are also trying to figure out what's going wrong and where.
In your case it seems you have updated everything but still the issue is there, please check these migration tips: github.com/joomdev/Astroid-Framework/wiki/Migrating-to-v2.4x

Let us know if these were helpful, if not then please share you joomla site backend details on This email address is being protected from spambots. You need JavaScript enabled to view it. along with this forum link, there is a chance a conflict between Astroid and any other extension, might be.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The topic has been locked.

Astroid 2.4.1 & Astroid Zero Template 2.4.0 Error 0 2 weeks 5 days ago #24210

  • Nidzo
  • Nidzo's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
Same problem with stacked menu on one site.

The topic has been locked.
Moderators: chandandeep
Time to create page: 0.413 seconds