fbpx

Trick or Treat - 30% OFF - Coupon Code: SCARY20 Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: (SOLVED)Joomla 4 - Blog Layout issue Astroid 2.4.1

Joomla 4 - Blog Layout issue Astroid 2.4.1 1 month 2 weeks ago #24279

  • vkengo
  • vkengo's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi,
I've installed Astroid 2.4.1 on Joomla 4 and have this error when loading a blog layout, same error on both templates (Zero & One). No problem when using default template Cassiopiero.

Also above articles there is label that says "Expired', shows only when using Astroid templates inside the h2 headline: <span class="label label-warning">Expired</span>.

Warning: require_once(C:\laragon\www\joomla\v4\test/components/com_content/models/category.php): failed to open stream: No such file or directory in C:\laragon\www\joomla\v4\test\templates\astroid_template_zero\html\com_content\category\blog.php on line 9

Fatal error: require_once(): Failed opening required 'C:\laragon\www\joomla\v4\test/components/com_content/models/category.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\joomla\v4\test\templates\astroid_template_zero\html\com_content\category\blog.php on line 9

PHP: 7.4.9
Joomla! 4.0.0-beta4-dev
Apache/2.4.35 (Laragon local server)

Thanks,
V.
The topic has been locked.

Joomla 4 - Blog Layout issue Astroid 2.4.1 1 month 2 weeks ago #24280

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4153
  • Thank you received: 609
  • Karma: 108
Hello,

Some manual work is needed to make it work on J4. This should do www.joomdev.com/blog/entry/design-joomla...th-astroid-framework

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.

Joomla 4 - Blog Layout issue Astroid 2.4.1 1 month 2 weeks ago #24301

  • vkengo
  • vkengo's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Perfect.
That solved both issues.
V.
The topic has been locked.

Joomla 4 - Blog Layout issue Astroid 2.4.1 1 month 2 weeks ago #24306

  • nishtha
  • nishtha's Avatar
  • Online
  • Moderator
  • Posts: 1409
  • Thank you received: 137
  • Karma: 18
Hi,

Great! Problem solved. Do let us know if you have any more issues with this.
Topic is now closed.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The topic has been locked.
Moderators: chandandeep
Time to create page: 0.316 seconds
Cron Job Starts