fbpx

Astroid 2.4 Landed with Joomla 4 Compatibility Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: Missing something with animation

Missing something with animation 4 weeks 1 day ago #24680

  • anotart
  • anotart's Avatar
  • Offline
  • Junior Member
  • Posts: 20
  • Karma: 0
Hi,
I had an animated wave in my footer-1 position that was working fine. I believe it stopped working after I updated the framework to 2.41. I am not seeing any clues -- I even tried a different wave implementation. Do you have any suggestions for things I can try? The site is notarthomas.net
Thank you
Last Edit: 4 weeks 1 day ago by anotart.
The administrator has disabled public write access.

Missing something with animation 4 weeks 11 hours ago #24708

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4131
  • Thank you received: 605
  • Karma: 107
Hi,

Make sure you are running the latest version of the framework and template as well.

Some documentation on the upgrade & manual fixes: github.com/joomdev/Astroid-Framework/wiki/Migrating-to-v2.4x

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Missing something with animation 2 weeks 5 days ago #24941

  • anotart
  • anotart's Avatar
  • Offline
  • Junior Member
  • Posts: 20
  • Karma: 0
Hi Chetan,

Sorry for the delay -- had issues with family that took me from work for a while.

I'm finding out that I have more problems than just the animation. I also did an override for the album page layout that worked fine before the update using css grid. That page is no longer recognizing the grid. This is the first time I did an override like this and used grid, so I'm struggling with figuring out what is happening. However, I copied the code to a development tool and it did recognize what I was doing correctly, so it appears it is related to the upgrade.

I looked at the github information and made all the changes under template except "Template Folder Structure". I wasn't sure what that was. And, the content further down the page is all over my head.

I've spent days of time trying to figure this out -- am so frustrated because it was all working before the update. I tried turning on debug and error reporting -- neither of those showed me anything.

I really appreciate any help you can give me to get this resolved.
The administrator has disabled public write access.

Missing something with animation 2 weeks 3 days ago #24949

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4131
  • Thank you received: 605
  • Karma: 107
Hello,

I hope things are well with the family now.

Follow the steps below and if things still don't work, email me the login information (backend and FTP) for your site and I'll take a look (This email address is being protected from spambots. You need JavaScript enabled to view it.).
1. rename the folder html to html_old in your template folder.
2. rename the folder frontend to frontend_old in your template folder.
3. reinstall the template.

At this point, everything should go back to normal and any custom overrides you may have created will have stopped working.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Missing something with animation 2 weeks 1 day ago #24992

  • anotart
  • anotart's Avatar
  • Offline
  • Junior Member
  • Posts: 20
  • Karma: 0
Hi Chetan,

My father passed now two weeks ago -- so been distracted, but things are settling slowly, thanks.

I did a number of things over the weekend -- and finally got rid of the css grid I was using (that worked before the upgrade) and replaced it with bootstrap. So, my article override called "album" finally went back to what I had before the update. Just so you know, I did a bunch of tests over the weekend -- started a whole new installation using prostar -- css grid worked; installed fresh Joomla/fresh Astroid Framework and Zero Template and css grid stopped. Uninstalled the Framework and template and reinstalled -- no change. That is when I got smart and changed approach. So this problem is resolved with a workaround.

I'm going to give up on the animated wave for now, but maybe you can help me understand something else. I am trying to make the text in the top bar a smaller font than the body font-size. I've tried using custom css (not working) and tried adding a class in the layout (not working). A file called compiled xxxxx.css seems to be taking precedent. I'm having that trouble with some other things I've tried to customize -- but not everything. Even !Important doesn't make a difference. Can you help me understand that?

Thanks so much for your help,
Anne
The administrator has disabled public write access.

Missing something with animation 2 weeks 1 day ago #24994

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4131
  • Thank you received: 605
  • Karma: 107
Hi Anne,

I am sorry to hear about your father. I hope he's at peace, where-ever that may be!

The compiled-xxx.css file is the file containing all the SCSS files of the template. If you write nested CSS and start with the ID of the section, it would definatelly take priority over the compiled.css file and would work just fine.

For example, instead of writing.
a.link {color:black;}

write:
#section-xxx a.link{color:black;}

Hope this helps!
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Missing something with animation 5 days 13 hours ago #25234

  • anotart
  • anotart's Avatar
  • Offline
  • Junior Member
  • Posts: 20
  • Karma: 0
Hi,

Sorry for the delay -- I was focusing on another area of the site. This sounded easy, but I'm missing something.

Do I put that in my custom.css file? I want to make the top bar font smaller on notarthomas.net. I added this to my custom.css:

#ts-551539321230222 {
font-size: 13px !important;
}

If that is not the correct file, do I need to worry about updates overwriting?

Thanks for your help -- and kind comment.

Anne
Last Edit: 5 days 13 hours ago by anotart.
The administrator has disabled public write access.

Missing something with animation 2 days 8 hours ago #25266

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4131
  • Thank you received: 605
  • Karma: 107
Anne,

You can add this either in the custom.css file or in the backend itself.
docs.joomdev.com/article/astroid-custom-css/

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.370 seconds
Cron Job Starts