fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: No image caption with featured articles

No image caption with featured articles 6 months 3 weeks ago #28409

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
Hello,

Site: kunstbauten.de Joomla! 3.9.24 Astroid Framework 2.5.1

with Astroid Template One 1.3.1 overrides in place html/com_content/featured/default.php and html/com_content/article/default.php image captions for intro and article image are not displayed!

I have overwritten that both files with correspondig files from Astroid Template 1.2 and now captions are displayed again

In category view image captions are not displayed too. Have a look at first article on www.kunstbauten.de/de/installationen.html (that image should have a caption!)

Please address these bugs in the next release!

kind regards

Markward Kufleitner
The administrator has disabled public write access.

No image caption with featured articles 6 months 2 weeks ago #28533

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
We don't speak here about WordPress themes. I talk about the Joomla! template One 1.3.1 with Astroid Framework 2.5.1.
With version 1.2 of template One captions (entered in backend at both article images) are working. With version 1.3.1 they do not work.
The administrator has disabled public write access.

No image caption with featured articles 6 months 2 weeks ago #28535

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Thank was a spammer please ignore him.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

No image caption with featured articles 6 months 1 week ago #28870

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
Problem still persists with Astroid 2.5.2 and Template One 1.3.2!

Please fix this bug. Please have a look at article images of first article on kunstbauten.de both images have captions entered in backend image option, but captions do not show up in frontend. They showed up formerly with Astroid 2.4.7 and corresponding Template One. Now something is broken there!

kind regards

Markward
Last Edit: 6 months 1 week ago by Ethlaegil.
The administrator has disabled public write access.

No image caption with featured articles 6 months 1 day ago #28991

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2436
  • Thank you received: 218
  • Karma: 36
Sorry for the delay, and thanks for reporting we'll solve this in the upcoming Astroid updates.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

No image caption with featured articles 1 month 3 weeks ago #30469

  • Ethlaegil
  • Ethlaegil's Avatar
  • Offline
  • New Member
  • Posts: 17
  • Thank you received: 1
  • Karma: 0
I finally found out, how to solve this bug. I added in

/html/featured/default.php, /html/article/default.php and /html/category/blog.php just one row after

defined('_JEXEC') or die;

this code: JHtml::_('behavior.caption');

now all image captions are working like a charm

Just if anybody needs this workaround

kind regards

Markward
The administrator has disabled public write access.

No image caption with featured articles 1 month 3 weeks ago #30472

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4593
  • Thank you received: 648
  • Karma: 116
Thanks for the solution. We will implement it.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.361 seconds
Cron Job Starts