fbpx

Astroid 2.4 Landed with Joomla 4 Compatibility Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: PHP Deprecated Errors

PHP Deprecated Errors 10 months 6 days ago #19090

  • nobicycle
  • nobicycle's Avatar
  • Offline
  • Junior Member
  • Posts: 29
  • Karma: 0
Hello,

Error reporting is set to

error_reporting = E_ALL & ~(E_NOTICE|E_WARNING)

I am finding many PHP Deprecated errors, such as:
PHP Deprecated: Array and string offset access syntax with curly braces is deprecated

Full configuration in attached zip of:
  • /tmp/system-info.txt
  • /etc/php/php.ini
  • /etc/nginx/nginx.conf
  • /etc/nginx/sites-available/bizx
  • /srv/http/bizx/configuration.php
  • /var/log/nginx/bizx/error_log
Attachments:
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 5 days ago #19112

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3805
  • Thank you received: 583
  • Karma: 99
Hello,

Please confirm the PHP version.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 4 days ago #19148

  • nobicycle
  • nobicycle's Avatar
  • Offline
  • Junior Member
  • Posts: 29
  • Karma: 0
$ php -v
PHP 7.4.0 (cli) (built: Nov 30 2019 10:43:49) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies


Hi, I attached all logs and details like this in the zip file
In the future, I'll just post it in the forum message.

Regards
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 4 days ago #19149

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3805
  • Thank you received: 583
  • Karma: 99
Hello,

Thanks for sharing the information. Try with PHP v7.2.0 or v7.3.0.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 4 days ago #19174

  • nobicycle
  • nobicycle's Avatar
  • Offline
  • Junior Member
  • Posts: 29
  • Karma: 0
Hello
PHP is now 7.2
No errors in the web server log. However I get a Notice
Notice: Trying to access array offset on value of type bool in /srv/http/bizx/libraries/nextend2/nextend/library/libraries/assets/less/lessc.php on line 614
even though Error Reporting is set to none in Joomla Administration.
Please see attached images for proof.

In addition
$ grep error_reporting /etc/php72/php.ini
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED

The only explanation I can see is that third party Nextend are changing error reporting in their code.
Attachments:
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 3 days ago #19206

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3805
  • Thank you received: 583
  • Karma: 99
You have to update the SmartSlider3. Please update
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 3 days ago #19215

  • nobicycle
  • nobicycle's Avatar
  • Offline
  • Junior Member
  • Posts: 29
  • Karma: 0
chandandeep wrote:
You have to update the SmartSlider3. Please update

Are you aware of Joomladev instructions to customers? to NOT try to update third party extensions bundled in templates, but to wait until they are updated by Joomladev? Unless they need all the PRO functionality, in which case they might buy the third party extension.

Looks like it is time for Joomladev to update this template'[s third party bundled SmartSlider3, otherwise Joomladev's template is unusable.

Please advise.
The administrator has disabled public write access.

PHP Deprecated Errors 10 months 1 day ago #19298

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3805
  • Thank you received: 583
  • Karma: 99
Hello,
You can simply download the extension from your download area. There will be an activated version with latest update. Install it and you are done.

PS: You don't need to buy it from the extension developer.
Let me know if you still have any issue.

Thanks.
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
The following user(s) said Thank You: nobicycle
Moderators: chandandeep
Time to create page: 0.377 seconds