JoomDev: Error 1064 with sub category (1/1)
Welcome, Guest
Username: Password: Remember me

TOPIC: Error 1064 with sub category

Error 1064 with sub category 5 days 7 hours ago #8294

  • seabird
  • seabird's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
Hello,

When I submit an item in frontend with form in a sub category. I have an error 1064.
JD BOSTON
1064
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1

the item is in the category , but I have this error only with sub category
It's Ok when I submit on backend, I have no error

Thanks,

Regards,

Eric
Attachments:
Last Edit: 5 days 7 hours ago by seabird.
The administrator has disabled public write access.

Error 1064 with sub category 5 days 6 hours ago #8295

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 985
  • Thank you received: 146
  • Karma: 25
Hello,

Please enable debug and error reporting and you'll see a track of what is causing the error.

Read more about how you can enable debug here: www.joomdev.com/blog/entry/how-to-enable...-and-error-reporting

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Error 1064 with sub category 5 days 6 hours ago #8296

  • seabird
  • seabird's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
Hello,
I have enable error reporting. there is nothing in addition to the error 1064.

However, I do not have the error if I modify an article already created.

Regards,

Eric
The administrator has disabled public write access.

Error 1064 with sub category 5 days 6 hours ago #8297

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 985
  • Thank you received: 146
  • Karma: 25
Hi Eric,

Enabling the debug will give you the exact file/function causing the error. Please be sure that you have debug & error reporting enabled.

It's weird that the error is happening with articles. Would really help looking at the debug tracelog.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Error 1064 with sub category 5 days 4 hours ago #8298

  • seabird
  • seabird's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
Hi ,

I have enabled debug and error reporting to developer . But I do not know more. I have only error 1064 with some Notice and Deprecated method in frontend

Eric
Last Edit: 5 days 4 hours ago by seabird.
The administrator has disabled public write access.

Error 1064 with sub category 5 days 3 hours ago #8299

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 985
  • Thank you received: 146
  • Karma: 25
Hi Eric,

I understand you have enabled the debug and can't see any errors.

The error "You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1" isn't a common Joomla error and is there because of probably a third party extension or other poorly written code.

I'd suggest you review any recent major changes that you may have made to your website?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Error 1064 with sub category 5 days 2 hours ago #8300

  • seabird
  • seabird's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
Hi ,

I see . There a problem with rewrite seo and form .
I desactivated rewrite for url submit form. It's OK now

Eric
The administrator has disabled public write access.

Error 1064 with sub category 5 days 2 hours ago #8301

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 985
  • Thank you received: 146
  • Karma: 25
Hi Eric,

Glad it solved it yourself.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Time to create page: 0.383 seconds