fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Exclude Component JDBuilder from Module Assignments

Exclude Component JDBuilder from Module Assignments 2 months 4 days ago #26668

  • dankra
  • dankra's Avatar
  • Offline
  • Premium Member
  • Posts: 85
  • Thank you received: 1
  • Karma: 1
This doesn't seem to be working for live preview or when viewing in browser link.

It's rather annoying when trying to adjust spacing, etc. for full browser view. Please advise!
Last Edit: 2 months 4 days ago by dankra. Reason: yup
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 2 months 3 days ago #26681

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 2167
  • Thank you received: 190
  • Karma: 29
Hi,

Can you please be a little more elaborative and provide clear screenshots of the issue.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 2 months 3 days ago #26709

  • dankra
  • dankra's Avatar
  • Offline
  • Premium Member
  • Posts: 85
  • Thank you received: 1
  • Karma: 1
The link in my original post clearly demonstrates what I'm discussing here. Can you please click that link!

You will see modules that overlay page content (on the right position) which occurs in Live Preview. These modules Assignments are set to be excluded in Component -> JDBuilder see attach graphic below.
Attachments:
Last Edit: 2 months 3 days ago by dankra.
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 2 months 1 day ago #26753

  • earang
  • earang's Avatar
  • Offline
  • Senior Member
  • Posts: 52
  • Thank you received: 1
  • Karma: 0
Hi

Your link is working properly,

Usually the module assignment excluding is done through excluding Menu assignment tab in module settings as a better solution to render your page without the module (J3)

Go to: Extensions/modules/youModule and find Menu assignment tab and then exclude the page that you don't want the module to appear on it. The page should has a menu item and alias to choose it.
I'm not a newbie, I'm a Joomla user since 2008, with advanced skills in managing it. I'm also a Linux system administrator. ^_^
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26823

  • dankra
  • dankra's Avatar
  • Offline
  • Premium Member
  • Posts: 85
  • Thank you received: 1
  • Karma: 1
Can someone on the Joomdev team please test if you can duplicate this problem? I have provide additional screenshots.
  • The first pic clearly shows I have set the module to Exclude JD Builder in the module Assignment for the Right Position module.
  • The second pic clearly shows the module overlayed on the Live Preview of a JDBuilder page.

Again, please review these requests better! You guys have my email address. Now I have waited six days and still no solution to this request for help. BTW @earang I had to turn off the module completely a few days ago to preview the page for the client. This is why I was trying to solve the problem many days ago!
Attachments:
Last Edit: 1 month 4 weeks ago by dankra.
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26860

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4197
  • Thank you received: 615
  • Karma: 105
Hello,

Simple, Open the module, Go to Menu Assignment tab and exclude the menu item.

Thanks for @earang providing the solution.

Thanks,
Chandan
Attachments:
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
Last Edit: 1 month 4 weeks ago by chandandeep.
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26879

  • earang
  • earang's Avatar
  • Offline
  • Senior Member
  • Posts: 52
  • Thank you received: 1
  • Karma: 0
chandandeep wrote:
Thanks for @earang providing the solution.

I'm also getting lots of help from the team here, so I'm trying to help others as well Chandan, I use joomla since 12 years. I'm not newbie in joomla. so it's time to share some help ^_^

I might be advanced in use more than developing because in fact I'm not a programmer. But if using and assisting people will help the open source community to develop more so I'm here and I will always help. by the way I chose to update my whole website in the last few months with JD products because I believe of this team and jd products.

Regards
I'm not a newbie, I'm a Joomla user since 2008, with advanced skills in managing it. I'm also a Linux system administrator. ^_^
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26870

  • dankra
  • dankra's Avatar
  • Offline
  • Premium Member
  • Posts: 85
  • Thank you received: 1
  • Karma: 1
Chandan

I have done this before. I showed you the screenshot of the menu assignment in my VERY FIRST POST. Then I turned off the module to show my client a preview. That was when earring noticed it was OK but NOT fixed. They DID NOT provide a solution. NOW you are not providing a solution. IF you read and review the screenshots from my most recent post to this topic AND THEN, go look at the link I posted on my first message here, you will see THIS PROBLEM still exists in LIVE PREVIEW.

The module is set to EXCLUDE JDBuilder in the menu assignment but it still appears in Live Preview. IF necessary, can this request be escalated.

JD Builder v1.10.1
Astroid Framework 2.4.7
Astroid Package 2.2.3
Astroid Plugin 2.4.7
astroid_template_zero 2.4.2
Last Edit: 1 month 4 weeks ago by dankra.
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26878

  • earang
  • earang's Avatar
  • Offline
  • Senior Member
  • Posts: 52
  • Thank you received: 1
  • Karma: 0
Hello Dankra,

What I think after I seen the issue on your website that this module is set to appear on "All pages" on module settings and the fix is from there. look at the screenshot to understand what I mean: ( prnt.sc/wchp3i )

If excluding "menu item" doesn't work in the "module settings" then it's likely because of 2 reasons.

Firstly make sure that your module is not published in custom position, because this sometimes cause an issue in rendering the modules with some plugins.

Secondly Make sure that the module rendering is not handled by other plugin or module: for example some accordion modules require custom module published with content in order to import them an render them.

Also, in all cases you can simply deactivate the module position at all from your template layout and here I assume that you use astroid framework.

Another work around to do is to use another instance from the template that you use with only the pages that you need this module appear on them, and just deactivate the position of it on the main template instance. This work around is not a final solution but it might help.

Hopefully this will help you

Thanks
I'm not a newbie, I'm a Joomla user since 2008, with advanced skills in managing it. I'm also a Linux system administrator. ^_^
The administrator has disabled public write access.

Exclude Component JDBuilder from Module Assignments 1 month 4 weeks ago #26881

  • dankra
  • dankra's Avatar
  • Offline
  • Premium Member
  • Posts: 85
  • Thank you received: 1
  • Karma: 1
@earang

Thank you for your feedback, however this JDBuilder page has not even been published to ANY Joomla menus so How & Why would a menu assignment be applied to this page?

I was able to find a hidden menu that had the right module assigned to the "homepage" BUT NOT this JDBuilder page. This is my primary problem. If I activate modules on the RIGHT position of the Astroid Zero template, they display in JDBuilder Live Preview. This makes it difficult to build pages AND I cannot show them to my client for approval looking like that.

Again I have included the screen shot of the menu assignments for the custom Joomla module (not a third party module) You can see that I have set the Assignment to be EXCLUDED from JDBuilder and yet it will display in the Live Preview.

I really believe this needs to be escalated to your developers because JDBuilder is not listening to Joomla.
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: chandandeep
Time to create page: 0.507 seconds
Cron Job Starts