fbpx
Flat 60% off on Everything
Days
Hrs
Welcome, Guest
Username: Password: Remember me

TOPIC: Error page (404) not working

Error page (404) not working 2 years 10 months ago #6158

  • gberlisk
  • gberlisk's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
I'm getting this error:

Warning: require_once(/var/www/jdmedical/libraries/joomla/document/html/renderer/head.php): failed to open stream: No such file or directory in /var/www/jdmedical/templates/jd_medical/error.php on line 42

Fatal error: require_once(): Failed opening required '/var/www/jdmedical/libraries/joomla/document/html/renderer/head.php' (include_path='.:/usr/share/php') in /var/www/jdmedical/templates/jd_medical/error.php on line 42

When I've chacked the file system there is no "document" folder.

When I've looked at your demo page of JD medical, error page (404) is also not working?

Any idea?

Thanks
Gregor
The administrator has disabled public write access.

Error page (404) not working 2 years 10 months ago #6159

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4235
  • Thank you received: 620
  • Karma: 112
Hi Gregor,

We had released an update for this one a while back. I'll check again, for the movement, you can apply the following fix:

www.joomdev.com/forum/jd-dallas/1180-sol...ch-file-or-directory
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: gberlisk

Error page (404) not working 2 years 10 months ago #6160

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4235
  • Thank you received: 620
  • Karma: 112
Hi Gregor,

Try this, download and replace the following file with your error.php in ROOT/templates/jd_medical/ folder and that should fix it:

gist.github.com/chetanmadaan/9365bd3621ccc25ce3be3a35fc74aafd
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: gberlisk

Error page (404) not working 2 years 9 months ago #6173

  • gberlisk
  • gberlisk's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Thanks!
Problem solved.

Now I have another issue.
When put "Cooming soon" mode to yes I'm geting this:

0
expected color value: /var/www/fiziotri/templates/jd_medical/less/master.less on line 8.
Last Edit: 2 years 9 months ago by gberlisk.
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6174

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4235
  • Thank you received: 620
  • Karma: 112
Huh... It looks like you are missing a color, Can you try opening and saving the template again in the backend and make sure you have all the colors selected in the Preset Colors section?

www.joomdev.com/documentation/medical/#Preset_color

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6175

  • gberlisk
  • gberlisk's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
I have some strange behavior.
"Coming soon" page works fine. After puting site url into web browser the url is changed to www.somewebsite.com/?tmpl=comingsoon (?tmpl=comingsoon is added)
After saving template changes and refreshing the page www.somewebsite.com/?tmpl=comingsoon I get this error.
If I delete /?tmpl=comingsoon from url "coming soon" works fine again.
Last Edit: 2 years 9 months ago by gberlisk.
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6176

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4235
  • Thank you received: 620
  • Karma: 112
huh... Not sure what it could be. Can you email over your website url and Joomla backend login. I'd like to take a closer look if possible.
Email is This email address is being protected from spambots. You need JavaScript enabled to view it.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
Last Edit: 2 years 9 months ago by admin.
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6184

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4093
  • Thank you received: 605
  • Karma: 104
Hi,

Try this, download and replace the following file with your error.php in ROOT/templates/jd_medical/ folder and that should fix it:

gist.github.com/chandanndeep/ae74ed8047e2cdd51ed02220c38f8b0e

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6187

  • gberlisk
  • gberlisk's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Sorry, the same error after replacing error.php
("expected color value: /var/www/jdmedical/templates/jd_medical/less/master.less on line 8")
The administrator has disabled public write access.

Error page (404) not working 2 years 9 months ago #6188

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4093
  • Thank you received: 605
  • Karma: 104
Hi,

It's a cache issue. Please open in an incognito window.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 1.035 seconds