fbpx

An Exclusive Offer For You To Grab JD Builder Pro Check Deal of The Day

Welcome, Guest
Username: Password: Remember me

Like using Astroid?

Help us improve Astroid by providing some quick feedback.

Take the survey

TOPIC: JD Testimonials on Articles Blog

JD Testimonials on Articles Blog 4 months 1 day ago #17143

  • Joomill
  • Joomill's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Hi,

I would like to show the JD Testimonials module on a Articles » Category Blog page, but it doesn't load.
It keeps spinning and in the developers console i see: jQuery errors.

Can you have a look at it?
Thanks in advance.
Jeroen
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 1 day ago #17144

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
Hi Jeroen,

Can you provide a link to your website?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 19 hours ago #17149

  • Joomill
  • Joomill's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Thanks for the quick reply.

It is still on localhost.
But i think it was a caching problem, because today everything works fine.

Jeroen
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 9 hours ago #17153

  • Joomill
  • Joomill's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
maybe you can still have a look, because the problem is back and it seems to be in astroid in general and not specific for this template.
demo.joomill-templates.com/babette

At the footer there is the jd-testimonials which works fine.
When you go to the blog or to hikashop it keeps on spinning.
(TypeError: a is undefined)
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 5 hours ago #17154

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
Somehow, jQuery is being added on the blog page that's throwing the error so it's double jquery.
<script src="http://demo.joomill-templates.com/babette/templates/astroid_template_zero/js/vendor/bootstrap/jquery.min.js"></script>

Checking more info this.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 5 hours ago #17155

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
Doesn't happen on the demo blog page.

demo.joomdev.com/recruiter/toolbar/blog

I was able to publish the testimonials module on the blog page and it worked fine (it's not there anymore).

Investigating further!!!

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 5 hours ago #17156

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
Strange enough, I tried on my local with Blog Page and Testimonials module published and it worked just fine.

Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

JD Testimonials on Articles Blog 4 months 4 hours ago #17157

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
It's a Gif but Kunena seems compress them and break the animation. Point is it works.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

JD Testimonials on Articles Blog 3 months 4 weeks ago #17181

  • Joomill
  • Joomill's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Hi Chetan,

I think i found something.

I made a new/clean installation with the Astroid demo content package.
If you look at the Blog with sidebar view it works (like in your situation)
When you go to the Blog without sidebar view it keeps spinning.
So i tested and JD Testimonials only seems to work on the blog-view when the search module is published on that page.

I searched in the search override and found 2 lines of code which i added to top of JD Testimonials /tmpl/default.php
JHtml::_('jquery.framework');
JHtml::_('script', 'system/html5fallback.js', array('version' => 'auto', 'relative' => true, 'conditional' => 'lt IE 9'));

Now the module works on all pages.
There is only a conflict on the Hikashop Listings view but this can be solved by set the "Use Chosen library"-setting to "YES". (in he configuration / display tab)

Maybe this can help you (and others) to solve this problem.
I don't know what the impact is for other websites, but your devs can judge.

Have a good weekend,
Jeroen
The administrator has disabled public write access.

JD Testimonials on Articles Blog 3 months 4 weeks ago #17182

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 3124
  • Thank you received: 470
  • Karma: 101
Hi Jeroen,

This is very helpful. Thanks for the thorough follow ups. I removed it since it was really just copied from the core search module but isn't actually useful for anything but placeholders for IE9 or below.

github.com/joomdev/Astroid-Framework/com...ac479db6ec197455777b

Give the dev version another try bit.ly/astroiddev

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.265 seconds