fbpx

Summer Sale: Enjoy Flat 35% Discount on all the Joomla Products. No Coupon RequiredGrab the Deal Now!

Welcome, Guest
Username: Password: Remember me

TOPIC: Error when updating 'AcyMailing Starter' and JD Skill Set' in JD Seattle

Error when updating 'AcyMailing Starter' and JD Skill Set' in JD Seattle 3 months 1 week ago #28613

  • Bwian
  • Bwian's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi, my url is www.aerialshotz.co.uk (but only the quickstart it there at the moment)
I'm on Joomla 3.9.25
Template version 1.6
Astroid 2.4.1

I can install the Quickstart template with no issues, and I can update Joomla also no errors. There are 6 updates as well, they all update ok except :-

JD Skill Set - This gives an error '0 call to member function get() on Null
It dosn't crash the site, but it will not update.

AcyMailing Starter - This gives the message 'o call to undefined acym_rootURI()
I then loose both the back and frond end. All I get is 'Please install and activate Astroid Framework in order to use this template.'

All i can do is restore my backup.

I have used joomla for many years, but i am not familier with Astroid.
I belive my Astroid version is not the latest, but I am unsure how to update it.

Can someone help please.
Thanks
The administrator has disabled public write access.

Error when updating 'AcyMailing Starter' and JD Skill Set' in JD Seattle 3 months 1 week ago #28618

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4408
  • Thank you received: 640
  • Karma: 115
Hi,

Please ignore the JD Skill Set update for the member, it may be an issue with the XML file on our end.

For AcyMailing, It may be a PHP version issue or something else. I'd recommend installing the newer version of AcyMailing by downloading from their website directly. extensions.joomla.org/extension/acymailing-starter/

Astroid can be upgraded just by downloading/installing the latest version on top of what you already have.
Information about the latest astroid release is available here: www.joomdev.com/astroid/changelog

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Error when updating 'AcyMailing Starter' and JD Skill Set' in JD Seattle 3 months 1 week ago #28623

  • Bwian
  • Bwian's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi, thanks for the quick reply,
I have upgraded the Astroid to 2.5.1 and tried on PHP versions 7.3, 7.4 and 8.0
I have also downloaded the latest version from Acy Mailing.
It crashes every time with the same error.

Its frustrating as I cannot even access the back end, it totaly kills the site.
The administrator has disabled public write access.

Error when updating 'AcyMailing Starter' and JD Skill Set' in JD Seattle 3 months 1 week ago #28624

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4408
  • Thank you received: 640
  • Karma: 115
Is it breaking on Astroid Upgrade or AcyMailing Upgrade? in any event, I'd suggest don't upgrade the particular extension. If it's astroid. You can downgrade to the lower version just by reinstalling the lower version on top of the existing install and it will fix it.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.577 seconds
Cron Job Starts