fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Field localization

Field localization 9 months 2 weeks ago #22281

  • Nm
  • Nm's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Karma: 0
Hello!
Created an additional field (Layout tab). For example, for the sender's last name ("2Name"). But in the message that comes to the mail, the corresponding field is not translated into the desired language. The same with the additional field phone. Although, for example, everything works well for the "Name" field. How to make sure that all fields in incoming letters are translated into the correct one (Jumla admin language)?
Last Edit: 9 months 2 weeks ago by Nm.
The administrator has disabled public write access.

Field localization 9 months 2 weeks ago #22285

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4252
  • Thank you received: 623
  • Karma: 112
How about multiple forms. One for each language?
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Field localization 9 months 1 week ago #22288

  • Nm
  • Nm's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Karma: 0
I do not understand, please explain.
The administrator has disabled public write access.

Field localization 9 months 1 week ago #22370

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4252
  • Thank you received: 623
  • Karma: 112
Create 2 different modules (1 of each language), that way you can write the text of the language itself and publish the module to the desired language.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Field localization 9 months 9 hours ago #22618

  • Nm
  • Nm's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Karma: 0
Hello!
This option also does not work.
The administrator has disabled public write access.

Field localization 9 months 4 hours ago #22625

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4252
  • Thank you received: 623
  • Karma: 112
You are probably still not going it right or I am not understanding you are looking for.

Let's look at some screenshots please.
docs.joomdev.com/article/a-simple-guide-...ing-quality-support/
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Field localization 9 months 14 hours ago #22712

  • Nm
  • Nm's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Karma: 0
Hello!
I will explain the problem, still in the screenshot.
Fields marked in red (incoming message from the site) have the same settings as the rest. But for some reason they have English. And there must be a Russian. I attach a screenshot.
Attachments:
Last Edit: 9 months 14 hours ago by Nm.
The administrator has disabled public write access.

Field localization 9 months 13 hours ago #22713

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4252
  • Thank you received: 623
  • Karma: 112
Thank You,

That's the field name that appear's on the frontend. I don't know why it's going it. But technically speaking the field name is automatically added to the email based on your actual field names.

Could it be at your email client is translating those fields automatically (like sometimes gmail does)?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Field localization 8 months 3 weeks ago #22771

  • Nm
  • Nm's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Karma: 0
Hi!
All fields name can only be called in English, these are the JDSCF settings. But the label and placeholder I filled in Russian.
Some labels and placeholders, for example, for the "name" field in the incoming message of the field are normally displayed, but, for example, for the address field - not! It seems to me that something is not finalized in the JDSCF.
We don’t take into account the mail client now, we look at the mail through the web interface.
Last Edit: 8 months 3 weeks ago by Nm.
The administrator has disabled public write access.

Field localization 8 months 3 weeks ago #22780

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 177
  • Thank you received: 25
  • Karma: 2
Hi,

I tested the JDSCF at my end and the fields are working fine with different languages.

Might be your email client is translating those fields.

Check the screenshots attached for the test case.

Thanks.
Attachments:
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: akash, chandandeep
Time to create page: 0.512 seconds