fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: Recaptcha not showing on form

Recaptcha not showing on form 5 months 3 weeks ago #29646

Hi,

We have the captcha option selected on the contact form but no recaptcha is displaying, can you please assist? Is there another plugin I need to install to enable this? See attached screenshot showing captcha settings. I tried both 'Use Global' and 'captcha - reCAPTCHA' under the captcha type but no luck.

Jooma 3.9.11, website is for a client so I can provide the URL via email.

Thanks in advance :)
Attachments:
Last Edit: 5 months 3 weeks ago by alice.maserati.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 3 weeks ago #29649

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 4614
  • Thank you received: 652
  • Karma: 116
Hello,

Please follow this documentation. This will help you.

docs.joomla.org/J3.x:Google_ReCaptcha

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 3 weeks ago #29650

Hi, I've tried the steps to add a recaptcha v2 but it's still not showing up on the frontend.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 3 weeks ago #29651

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Hey Alice,

Check out this video.

It has all the detailed steps you need to enable the ReCaptcha.

One thing is missing in the video, that is after doing the steps in the video you need to set the default captcha in the global configuration.

Let me know, how it goes.

Thanks.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
Last Edit: 5 months 3 weeks ago by akash.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 3 weeks ago #29670

Hi, I followed those steps but the captcha still does not show correctly. It does not show until you submit the form, the page reloads, then it says 'Error- Please complete the CAPTCHA' and only then does the captcha show. I have set the default captcha in the global config and followed all steps in the video.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 3 weeks ago #29671

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Hey Alice,

Can you tell me which version of Recaptcha are you using?

The JD Simple Contact Form doesn't support Recaptcha v3 as of now.

I just tried all the steps mentioned in the video and it's working fine at my end.

There must be some configuration issue at your end.

Can you share your site URL with the page you're setting captcha on?

Let me know.

Thanks,
Akash
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 2 weeks ago #29775

Hi, recaptcha V2, the page is potsandmore.com.au/en/contact-us
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 2 weeks ago #29776

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Hey @alice,

Can you share your site credentials? So, I can have a look.

Share it on This email address is being protected from spambots. You need JavaScript enabled to view it. with the URL of this forum.

Let me know.

Thanks.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 1 week ago #29787

Unfortunately I am unable to provide login credentials as this is a site we are managing for a client. Is there anything else you can suggest?
The administrator has disabled public write access.

Recaptcha not showing on form 5 months 1 week ago #29789

  • akash
  • akash's Avatar
  • Offline
  • Moderator
  • Posts: 222
  • Thank you received: 30
  • Karma: 2
Alice,

I checked the page and I didn't found any captcha set on the form.

Please try to follow this video carefully and you'll surely able to show Recaptcha on your form.

Thanks.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: akash, chandandeep
Time to create page: 0.461 seconds
Cron Job Starts