fbpx

Trick or Treat - 30% OFF - Coupon Code: SCARY20 Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: Remove index.php

Remove index.php 1 year 8 months ago #12099

  • Crash
  • Crash's Avatar
  • Offline
  • Platinum Member
  • Posts: 479
  • Thank you received: 7
  • Karma: 0
Hi,
I want to remove index.php from the URL, but when I activate "Use URL Rewriting" it crashes all pages apart from the home page?
development.flawlesshairandbeautybar.co.uk/index.php
Regards,
Colin.
The administrator has disabled public write access.

Remove index.php 1 year 8 months ago #12102

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4151
  • Thank you received: 609
  • Karma: 108
Colin,

After you enable URL rewriting. Rename the file htaccess.txt to .htaccess and that should do it.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Remove index.php 1 year 8 months ago #12104

  • Crash
  • Crash's Avatar
  • Offline
  • Platinum Member
  • Posts: 479
  • Thank you received: 7
  • Karma: 0
Worked perfectly.
Thanks Chetan.

Regards,
Colin.
The administrator has disabled public write access.

Remove index.php 1 year 8 months ago #12110

  • Lalit Kumar
  • Lalit Kumar's Avatar
  • Offline
  • Moderator
  • Posts: 700
  • Thank you received: 96
  • Karma: 24
Great :)

Let us know if you have any query.

Thanks,
Lalit
Thank You,
If you like our support and products, tweet us at JoomDev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: Crash

Remove index.php 6 months 6 days ago #21657

I had already renamed to .htaccess before trying to turn on "Use URL rewriting".... would this work if I copied an original htaccess.txt from the original download of the template, uploaded that file via FTP, then made the switch on " Use URL rewriting" within Joomla, and then changed the name to .htaccess again?
The administrator has disabled public write access.

Remove index.php 6 months 6 days ago #21660

I went ahead and tried it anyways... didn't seem to help.

I also tried with a fresh htaccess.txt file to add the following code in (which I saw on another site), and then renamed .htaccess after setting the "Use URL Rewriting" Still gave the 500 error on all pages except the home page. Any other thoughts?

# Block out any script trying to base64_encode or base64_decode data within the URL
RewriteCond %{QUERY_STRING} base64_(en|de)code[^(]*\([^)]*\) [OR]
## IMPORTANT: If the above line throws an HTTP 500 error, replace it with these 2 lines:
# RewriteCond %{QUERY_STRING} base64_encode\(.*\) [OR]
# RewriteCond %{QUERY_STRING} base64_decode\(.*\) [OR]
The administrator has disabled public write access.

Remove index.php 6 months 5 days ago #21689

  • chandandeep
  • chandandeep's Avatar
  • Offline
  • Administrator
  • Posts: 3837
  • Thank you received: 586
  • Karma: 99
Hello,

I have shared a blog post. Please read. It will help.

www.joomlabeginner.com/blog/tutorials/61...endly-urls-in-joomla

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Remove index.php 6 months 5 days ago #21719

Thanks. I carefully followed all the steps in the blog post. .htacess already has that code in it. Both SEF URLS and URL Rewriting are turned on... but once URL Rewriting is turned on... I just get a 500 error for every page other than the home page. No idea how to fix this other than the code I posted above... which breaks the administrator end from working properly.
The administrator has disabled public write access.

Remove index.php 6 months 4 days ago #21737

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4151
  • Thank you received: 609
  • Karma: 108
I wish we could help further but it's probably something on your server.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.450 seconds
Cron Job Starts