JoomDev: (SOLVED)Sample data (quickstart) requirements (1/2)

Introducing astroid v2.0 with article types, custom badges and much more. Download Now

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: (SOLVED)Sample data (quickstart) requirements

Sample data (quickstart) requirements 6 days 8 minutes ago #8812

  • Akira
  • Akira's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
Hi, is there something specific about your sample data for templates?
I downloaded several and installed it (for example JD Austin Quickstart v1.1), but neither one works.

When I install Quickstart version WITHOUT sample data, they works (of course, they not look like a demo).

When I choose in installation JD Austin WITH sample data, it installs, and I can access administration,
but site doesn’t work and I only see :
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'system,editable FROM `#__nextend2_section_storage` WHERE `application` = 'sy' at line 1

But administration works, so when I disable your template in administration and choose Protostar or Beez3 from Joomla, they work (although, they are empty).

This problem is not happening in template only. I downloaded clean Joomla, I installed it with Joomla sample data, and it works.
Then I added your template JD Austin and it work also (without your sample data it look much different of course).
So my PHP and MySQL configuration is OK I guess. (newest MySQL, newest Apache, and PHP 5.6.38).

So why when I download your Quick start package with sample data, it doesn’t work and it showing that error?
(quick start version of templates from other websites works fine)
Last Edit: 6 days 3 minutes ago by Akira.
The administrator has disabled public write access.

Sample data (quickstart) requirements 5 days 19 hours ago #8813

  • admin
  • admin's Avatar
  • Online
  • Administrator
  • Posts: 1098
  • Thank you received: 156
  • Karma: 26
Hello,

This may have to do with your server limits.

Joomla tried to install the whole SQL in one shot and if you have the default server limits (max_execution_time = 30 seconds is one example), you may face this issue.

I'd say increase the basic PHP limits and then try the quickstart again.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Sample data (quickstart) requirements 5 days 17 hours ago #8814

  • Akira
  • Akira's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
Thanks for your time

I increased "max_execution_time" from 30 to 130 in PHP.ini, although installation originally took around 15 seconds.
Also I tried increasing:
script memory_limit from 128MB to 256M
upload_max_filesize from 80MB to 500MB
max_file_uploads from 10 to 100
mysql.cache_size from 1000 to 2000
I restarted Apache server, but no luck.

Installation still happen without errors, administration work, but page not.
I have no idea why. JD_austin_quickstart_v1.1.zip has 26 MB.

I tried install other templates from different sites, like 32 MB helix3_quickstart_j3_v2.5.5.zip, and it installs normally (just like 25 MB purity-iii for example).
What limit it could be? And why is only on templates from Joomdev.com?

I tried install jd_boston, same error, and then jd_seattle. That one has different error - 404, Component not found.
What I'm missing?
The administrator has disabled public write access.

Sample data (quickstart) requirements 5 days 17 hours ago #8815

  • admin
  • admin's Avatar
  • Online
  • Administrator
  • Posts: 1098
  • Thank you received: 156
  • Karma: 26
Phew!!! that escalated quickly!

How about this, send me the login to your cPanel (if possible) and I'll try and run the install for you.

This email address is being protected from spambots. You need JavaScript enabled to view it.

Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Sample data (quickstart) requirements 5 days 17 hours ago #8816

  • Akira
  • Akira's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
I'm not sure I understand your request.
I installing it on my localhost.
Its like, three clicks. Database is always new and empty.

I using MySQL 8.0, Apache 2.4.34, and PHP 5.6.38.
Newest Joomla installation with sample data works fine, other quickstart templates also.
Attachments:
Last Edit: 5 days 17 hours ago by Akira.
The administrator has disabled public write access.

Sample data (quickstart) requirements 5 days 17 hours ago #8817

  • admin
  • admin's Avatar
  • Online
  • Administrator
  • Posts: 1098
  • Thank you received: 156
  • Karma: 26
No problem.

If you are running localhost then never mind, I can't get the login anyways.

Let me debug this and get back to you here shortly.

Stay Put!
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Sample data (quickstart) requirements 4 days 23 hours ago #8824

  • admin
  • admin's Avatar
  • Online
  • Administrator
  • Posts: 1098
  • Thank you received: 156
  • Karma: 26
Hello,

One quick request here. Can you try installing smart slide in the quickstart installed Joomla and see if that fixes it.

You can download a copy here:
smartslider3.com/free-joomla-slider/

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Sample data (quickstart) requirements 4 days 23 hours ago #8825

  • Akira
  • Akira's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
This plugin is already installed in quickstart package, but when i click at it, i see same error. (see attachment)
Other installed components are ChronoForm6 (it works) and SP simple portfolio (it works).

I tried installed again, but no change.

BUT, i tried disabling it and now webpage work!
Without top slider of course.

So, why slider showing this error? Is something that it needs?
I tried installing it on fresh Joomla site and it produce same error inside administration:

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'system,editable FROM `#__nextend2_section_storage` WHERE `application` = 's' at line 1

So I guess its not problem with Joomladev template after all, but with this plugin.
But this error tells me literary nothing. MySQL server is working, pages are loading, I have no idea what syntax problem plugin describe and how to even debug it or correct it.
Attachments:
The administrator has disabled public write access.

Sample data (quickstart) requirements 4 days 23 hours ago #8826

  • admin
  • admin's Avatar
  • Online
  • Administrator
  • Posts: 1098
  • Thank you received: 156
  • Karma: 26
Hi again,

Can you enable debug in your Joomla config and that will display a much thorough error message along with a file location that's throwing it and post that back here please.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Sample data (quickstart) requirements 4 days 22 hours ago #8827

  • Akira
  • Akira's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
OK, message is longer now, but I still have no idea what is telling me (Snap1) and where I begin to solve this.

But it is not only this plugin I found out.

I try edit page in JD Austin through Content/Articles, I click on one page, like Portfolio, and it showing no text.
It shows Warning: JUser: :_load: Unable to load user with ID: 971

And then, in Database Queries, almost endless streams of "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT `data` FROM `#__session` WHERE `session_id` = '4kqc6ave2rhsqij78r86s' at line 1"
(Snap 2).
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: priyasingh
Time to create page: 0.402 seconds