fbpx
Welcome, Guest
Username: Password: Remember me

TOPIC: Form not sending, all fields are green

Form not sending, all fields are green 2 years 2 months ago #16230

  • MarcB
  • MarcB's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
Hey guys,

I'm testing a form and it won't send. All fields turn up green (ie. no errors) but it won't send me to the confirmation message and no mail is send.

Is there a limit in sending from on ip or something? Spam protection?
Attachments:
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16232

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4489
  • Thank you received: 646
  • Karma: 115
Hello Marc,

Couple of things to note here:
1. There is no limit to the number of emails in the form.
2. If you have enabled Ajax submission, try disabling it and see if that works.
3. Try testing emails in your Joomla global config SMTP settings to see if Joomla in general is able to send out emails.
4. There is a different between form not submitting and not sending emails. If you are able to see a success message after clicking the submit button and not getting the emails, it means either your configuration is incorrect (for email settings in the module) or your Joomla site is unable to send out emails.
If on the other end, you can't click submit and don't see an error or success message, the email part isn't even triggered and it has something to do with how you created the form or something else.

I hope you find the above helpful.
Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16237

  • MarcB
  • MarcB's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
1. Oke!
2. I have it enabled, but disabling it didn't improve
3. global SMTP settings are correct. Test mails are being send and other form with JD work
4. This is where the problem was. I had {Email:value} in the From Email field and that apparently failed.

I'll do some more tests on small forms to see.
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16238

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4489
  • Thank you received: 646
  • Karma: 115
Good Luck!

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16239

  • MarcB
  • MarcB's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
Where can I find which variable fields can be used in which Email options fields?
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16240

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4489
  • Thank you received: 646
  • Karma: 115
Marc,

You can use all fields, {fieldname:value} or {fieldname:label}
See: github.com/joomdev/JD-Simple-Contact-For...ster/helper.php#L297

github.com/joomdev/JD-Simple-Contact-For...ster/helper.php#L186

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: MarcB

Form not sending, all fields are green 2 years 2 months ago #16241

  • MarcB
  • MarcB's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
It's odd, what am I doing wrong here then?
Attachments:
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16242

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4489
  • Thank you received: 646
  • Karma: 115
You are doing everything right. Try looking in the Network tab in the developer console and expanding it would show the exact line number showing error.

On a second thought, try change the from email and name to be static values and see if that helps.

Last but not the least, some providers don't let you set from to be any email address but You can to a replyto instead.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16249

  • MarcB
  • MarcB's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
Hi Chetan,
Further investigation did show that enabling AJAX caused the problem.
When is AJAX usable? What does my site need for that?
The administrator has disabled public write access.

Form not sending, all fields are green 2 years 2 months ago #16260

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4489
  • Thank you received: 646
  • Karma: 115
Could be a few different things. Are you able to provide a link to your site?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: akash, chandandeep
Time to create page: 0.415 seconds
Cron Job Starts