fbpx

Trick or Treat - 30% OFF - Coupon Code: SCARY20 Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: JD Builder - Raw HTML element problem when I am saving.

JD Builder - Raw HTML element problem when I am saving. 3 months 4 weeks ago #23188

Hi,
I have a problem with iframe tag in Raw HTML element.
Every time I insert a
<iframe> </iframe>
tag, JD builder change the tag in
<i-frame></i-frame>
.
This is second time when is happening, every time for different sites.

For first site, I tried to replace iframe with [jmodule = "module_id"], but still is not working.

Regards,
Daniel (Eos Digital)
The administrator has disabled public write access.

JD Builder - Raw HTML element problem when I am saving. 3 months 3 weeks ago #23197

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4151
  • Thank you received: 609
  • Karma: 108
Hi Daniel,

The iframe issue isn't with JD Builder but with possibly another plugin that's doing it. I had the same issue with ark editor and disabling that fixed the issue.

The module ID should work. The minute you type the above syntax, do you see in the live preview "module id 230 will render here". If not, make sure there isn't special HTML in there copied along and try pasting the syntax directory in the CODE tab.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: eosdigital2020

JD Builder - Raw HTML element problem when I am saving. 3 months 3 weeks ago #23209

Hi Chetan,

Thanks for your answer. I put all of this on me, being a newbie in astroid framework. My astroid ``style`` is still in development :) .
Now, about other editor I could use...I don't use, I prefer codemirror Joomla ediftor, so there is not from another plugin. Maybe the last update of Joomla to 3.9.19, change something because codemirror were updated to last versoin.
For second issue, you have here a screenshot





And another thing...usually I don't use WYSIWYG part of the editor in JD Builder, because it can be tricky....I forgot to change editor in Joomla :lol:
First on this last site I've added youtube using iframe tag, because yout video element wasn't available. I was very happy when you returned to video element in JD Builder, as you can see, immediately I used. Somethig is happening.
Now you were right, changed editor from tiny mce to codemirror and now everything is OK.




You can close this topic and get a big thanks from me!

Kindest regards,
Daniel (Eos Digital)
The administrator has disabled public write access.

JD Builder - Raw HTML element problem when I am saving. 3 months 3 weeks ago #23210

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4151
  • Thank you received: 609
  • Karma: 108
Thanks for the brief reply.
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: chandandeep
Time to create page: 0.311 seconds