fbpx

Biggest Sale of the Year - Save 60% Now!!

Days
Hrs
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Only use the Off canvas menu

Only use the Off canvas menu 2 years 1 month ago #8946

  • kevinmo
  • kevinmo's Avatar
  • Offline
  • Senior Member
  • Posts: 48
  • Thank you received: 5
  • Karma: 0
The mobile menu is to limited in its function. I would rather have the ability to show more than just a single menu in mobile view and the off canvas option provides that. Is there a way to show the off canvas hamburger and disable the mobile menu completely? Really I think the mobile menu is a waste of time and the off canvas menu can be used in place of it, not to mention it gives more control over what I can show.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8947

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4174
  • Thank you received: 611
  • Karma: 110
Hi Kevin,

Thanks for the suggestion. The reason we made mobile menu (auto select) menu and not a module position like offcanvas is because of simplicity. A good percentage of the users would only want their menu in there without doing much and we don't want to over complicate it for them.

I do however agree that there should be a simple way to disable the mobile menu (who wants two hamburger icons anyway) and use offcanvas as a primary menu (you can publish the menu module to offcanvas and it styles just as the mobile menu).

For the movement you can make a small code edit to hide the mobile menu icon trigger.

This is under the assumption you are using the horizontal header layout.
Copy the file:
ROOT/templates/astroid-template-zeo/frontend/header/horizontal.php
to:
ROOT/templates/astroid-template-zeo/html/frontend/header/horizontal.php
(This is how you override astroid layout files more on that here: www.joomdev.com/documentation/astroid-fr...end-Folder-Overrides )

Once done, in the newly copied file, remove lines
30 - 35
<div class="d-flex flex-row justify-content-between">
      <div class="d-flex d-lg-none justify-content-start">
         <div class="header-mobilemenu-trigger d-lg-none burger-menu-button align-self-center" data-offcanvas="#astroid-mobilemenu" data-effect="mobilemenu-slide">
            <button class="button" type="button"><span class="box"><span class="inner"></span></span></button>
         </div>
      </div>

This should hide the mobile menu icon.

Thank you,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8949

  • kevinmo
  • kevinmo's Avatar
  • Offline
  • Senior Member
  • Posts: 48
  • Thank you received: 5
  • Karma: 0
Thanks for the detailed info, very much appreciated and likewise the super fast reply! So I did as you suggested and thanks for this tip on overrides, very handy to know how this is handled but I did this and what it did was remove the off canvas hamburger the mobile menu however persists.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8950

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4174
  • Thank you received: 611
  • Karma: 110
Not a problem!

Is this online, Can you share the link?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8951

  • kevinmo
  • kevinmo's Avatar
  • Offline
  • Senior Member
  • Posts: 48
  • Thank you received: 5
  • Karma: 0
Yes, sorry I should have already included that.

usmc-blacksheep.org
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8952

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4174
  • Thank you received: 611
  • Karma: 110
I think you accidentally removed the offcanvas code.

Try replacing your horizontal.php override with the following:

gist.github.com/chetanmadaan/ea03949dd173761085e13716ec504874

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8954

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4174
  • Thank you received: 611
  • Karma: 110
On a site node, your site looks really well done by the way, the colors and all look great.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
The following user(s) said Thank You: kevinmo

Only use the Off canvas menu 2 years 1 month ago #8955

  • kevinmo
  • kevinmo's Avatar
  • Offline
  • Senior Member
  • Posts: 48
  • Thank you received: 5
  • Karma: 0
Thanks for all your help Chetan, I replaced the code with what you shared and still, the mobile menu persists and the off canvas is gone.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8956

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4174
  • Thank you received: 611
  • Karma: 110
If you can share the FTP via email, I'd love to take a look (email is This email address is being protected from spambots. You need JavaScript enabled to view it.).

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.

Only use the Off canvas menu 2 years 1 month ago #8958

  • kevinmo
  • kevinmo's Avatar
  • Offline
  • Senior Member
  • Posts: 48
  • Thank you received: 5
  • Karma: 0
I see you added stacked.php to the override. Not sure if its this file or some other modification to the horizontal.php file but now the only menu showing is the mobile menu. The normal main menu is gone as is the off canvas menu. This is not going to work, sure hope you have some thoughts or are working on a different workaround?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: chandandeep
Time to create page: 0.407 seconds