fbpx

Xmas is coming - Grab 30% Discount on all Joomla Template. Coupon Code: PRECHRISTMAS Unlock Offer

Welcome, Guest
Username: Password: Remember me

TOPIC: Upgrade to PHP 7.1: Fatal error: require_once(): Failed open

Upgrade to PHP 7.1: Fatal error: require_once(): Failed open 1 week 3 days ago #9787

  • davewx
  • davewx's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
I'm using J3.91 on 3 sites. Upgrading to PHP7.1 works for 2/3. The third produces this error.
Complete error is: Fatal error: require_once(): Failed opening required '...public_html/libraries/joomla/document/html/renderer/head.php' (include_path='.:/opt/php71/lib/php') in .../public_html/templates/baryonic/error.php on line 78
Here is error.php lines 78 to 82:
require_once(JPATH_LIBRARIES.'/joomla/document/html/renderer/head.php');
$header_renderer = new JDocumentRendererHead($doc);
$header_contents = $header_renderer->render(null);
ob_start();
?>
I'm not a coder, so this is all Greek to me. I suspect I need a tweak to the code. Can anyone help?
Thanks in advance.
The administrator has disabled public write access.

Upgrade to PHP 7.1: Fatal error: require_once(): Failed open 1 week 3 days ago #9790

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 1331
  • Thank you received: 188
  • Karma: 37
Hello,

The code above isn't of Astroid. You are using some other template. You have to post in the correct category in order to get help.

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The administrator has disabled public write access.
Moderators: priyasingh
Time to create page: 0.367 seconds