fbpx

Biggest Sale of the Year - Save 60% Now!! Grab the Deal

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Default Typography using custom.CSS doesn´t work

Default Typography using custom.CSS doesn´t work 9 months 3 days ago #20434

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
Hello. In Astroid, under Typography, I setted to Default and Inherited all elements (body, h1.. etc), in order to manage all fonts of all my template styles (languages) at the same time using custom.css. The most of them works properly from custom.css, but when I deactivate Menu Typography and / or H5 Typography, the other fonts lost it properties and custom.css doesn´t work. Thank you.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 9 months 1 day ago #20448

  • Lalit Kumar
  • Lalit Kumar's Avatar
  • Offline
  • Moderator
  • Posts: 700
  • Thank you received: 96
  • Karma: 24
Hello,

Please tell me where you deactivate the Menu Typography and/or H5 Typography? in the custom.css OR Astroid Framework?
Thanks,
Lalit
Thank You,
If you like our support and products, tweet us at JoomDev and let the world know about it.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 9 months 14 hours ago #20468

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
Hello. In Astroid, under Typography, I setted to Default and Inherited all elements...
Attachments:
Last Edit: 9 months 14 hours ago by vsdmub.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 4 weeks ago #20495

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3891
  • Thank you received: 595
  • Karma: 101
Hello,

Please share the site URL.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 4 weeks ago #20529

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
Here you go:
astroid.joomla.com/blog-2/47-typography.html
In Astroid, under Typography, I setted to Default and Inherited all elements.
Under Custom Code / Custom CSS Files / I wrote: custom.css
I have upload the file custom.css to: /templates/astroid_template_zero/css (The file is attached below as txt).
I attached an image what shows how h3 should be shown. All styles should be look like this Open Sans, but for some reason they don´t work.

Thank you.
Attachments:
Last Edit: 8 months 4 weeks ago by vsdmub.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 4 weeks ago #20530

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
The Console of Chrome DevTools shows this message:
Refused to apply style from 'astroid.joomla.com/custom.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

Additionaly It's extrange because this path is not correct.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 4 weeks ago #20543

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3891
  • Thank you received: 595
  • Karma: 101
Hello,

For custom.css file. You don't have to write custom.css in Custom CSS Files's box. Just create custom.css file in css folder. File will be added automatically and error will be solved.

Thanks,
Chandan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 3 weeks ago #20564

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
Ok. thank you. I have removed the text "custom.css" from Custom CSS Files's box. The error "Refused to apply style from..." has gone. However, the issue with the fonts remains. All Fonts styles should be like the attached one. Please verify it:
astroid.joomla.com/blog-2/47-typography.html

The font "Open sans" and the font-weight appear on DevTools but are not taken.
Attachments:
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 3 weeks ago #20567

  • chandandeep
  • chandandeep's Avatar
  • Online
  • Administrator
  • Posts: 3891
  • Thank you received: 595
  • Karma: 101
Hello,

I checked, "Open sans" font is working. See the screenshot.

Thanks,
Chandan
Attachments:
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The administrator has disabled public write access.

Default Typography using custom.CSS doesn´t work 8 months 2 weeks ago #20710

  • vsdmub
  • vsdmub's Avatar
  • Offline
  • Senior Member
  • Posts: 73
  • Karma: 0
Hello. Not really. The font shown in your screenshot isn't open sans with font-weight 200. This font is thinner, like you can see in my previous attached file. I've used DevTools from Firefox and that font is not taken for the browsers. Please see the attachment. Arial is underlined (selected) and it is shown instead Open Sans.

This only happen when I use custom.css to set the font. If I set Open Sans with font-weight 200 in Astroid Typography, it works well. You can change Typography and see it for yourself:

astroid.joomla.com/administrator/
User: Acymailing
Pass: Acymailing

Extensions / Templates / Styles / Astroid Template Zero - Default Astroid / Template options / Typhography

Thank you for your help.
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: chandandeep
Time to create page: 0.422 seconds