fbpx

Astroid 2.4 Landed with Joomla 4 Compatibility Download Now

Welcome, Guest
Username: Password: Remember me

TOPIC: (SOLVED)Link to article does not work

Link to article does not work 3 months 6 days ago #23404

Hi,
I am new to the Astroid framework, but so far I love working with it. I am making a one page website with Astroid template. So far, everything is oke. But I just can't get a link to an article working, I hope someone will help me.
I have made an artical in Joomla with the "privacy and cookie statement".
Now I want to make a link in the astroid footer that says: "Privacy and Cookie statement" and when people click on it, the page (article) with the cookie text should appear. I've tried everything I can think of but it won't work. I keep getting redirected to the same page, or a blank page with only the menu of the site showing.
This is what I have done:
1- I made a module with html called "cookie and privacy". In the module I make the link by clicking "article" (the article wih the privacy and cookie statement I had made). And link it to the position "footer-1".
2- In the astroid template I went to "Layout" and made a module position in the footer-1.

The link and tekst show in the footer, but when I click on it, I get sent back to the homepage.
I also tried with making a hidden menu item called "cookieprivacy"' with an url link: #cookieprivacy
In the Astroid template, in the footer section I named the Custom ID #cookieprivacy" But this does not work either. When I click on the link in the footer on the website, i get redirected to a blank page with only the menu showing.
What am I doing wrong?? Please help.
Thank you!
The topic has been locked.

Link to article does not work 3 months 4 days ago #23421

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4145
  • Thank you received: 607
  • Karma: 108
Hi,

Thanks for explaining. It'd be easier to take a look at the problem and help you with a solution.

Can you post a link back to your website please?

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.
The following user(s) said Thank You: Gremmyding30

Link to article does not work 3 months 3 days ago #23433

Hi Chetan,
Thank you so much for your response and willing to have a look at it.
The link to the website is: nieuw.boedelcentrumxl.nl
I've tried to make the links in several way, but doesn't work. (see the links in the footer)

Thanks! :)
The topic has been locked.

Link to article does not work 3 months 3 days ago #23435

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Posts: 4145
  • Thank you received: 607
  • Karma: 108
Hi,

I think you must have removed the component layout type in the layout manager.

Please see this tutorial: docs.joomdev.com/article/layout-manager-for-dummies/

Thanks,
Chetan
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.
The topic has been locked.
The following user(s) said Thank You: Gremmyding30

Link to article does not work 3 months 3 days ago #23439

Hi Chetan,

You are right! It was because of the missing component area! Thank you so much!!
So much appreciated! :cheer:
The topic has been locked.

Link to article does not work 3 months 2 days ago #23449

  • nishtha
  • nishtha's Avatar
  • Offline
  • Moderator
  • Posts: 1386
  • Thank you received: 135
  • Karma: 17
Hi,

Amazing problem solved, topic is now closed.

Thanks,
Nishtha
Thank You,
If you like our support and products, tweet us at joomdev and let the world know about it.

To know more about products check out the their documentation.
The topic has been locked.
Moderators: chandandeep
Time to create page: 0.702 seconds
Cron Job Starts